
 

 

 

 

 

 

 

 

 

 

Report Designer 

 

“ISIMSOFTWARE-

REPORT” 

 
Version 1.2.1 

 

 

User Manual 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
© 2022 Isimsoftware. All Rights Reserved 



Report Designer "IsimsoftwareReport" User 

Manual 
2  

Contents 

1. Introduction ..................................................................................................................................................... 3 

2. Terms & Definitions ........................................................................................................................................ 3 

3. User interface .................................................................................................................................................. 3 

3.1. Main windows ........................................................................................................................................ 3 

3.2. Main menu .............................................................................................................................................. 4 

3.2.1. File menu items ................................................................................................................................. 4 

3.2.2. Objects menu items ........................................................................................................................... 4 

3.2.3. View menu items ............................................................................................................................... 4 

3.2.4. Options menu items ........................................................................................................................... 4 

3.2.5. Help menu items ................................................................................................................................ 5 

4. Working with the software .............................................................................................................................. 5 

4.1. The basic concepts .................................................................................................................................. 5 

4.1.1. Page Margins section ......................................................................................................................... 5 

4.1.2. Report Header section ....................................................................................................................... 5 

4.1.3. Table Header section ......................................................................................................................... 6 

4.1.4. Group Header section ........................................................................................................................ 6 

4.1.5. Data Rows section ............................................................................................................................. 6 

4.1.6. Report Footer section ......................................................................................................................... 6 

4.2. Edit a report template.............................................................................................................................. 6 

4.2.1. Select an object .................................................................................................................................. 6 

4.2.2. Change the position of the object ...................................................................................................... 7 

4.2.3. Resize an object ................................................................................................................................. 7 

4.2.4. Change object attributes .................................................................................................................... 7 

4.2.5. Add an object ..................................................................................................................................... 7 

4.2.6. Delete an object ................................................................................................................................. 7 

4.3. Create a report template .......................................................................................................................... 8 

4.4. Save a report template ............................................................................................................................ 8 

4.5. View and print a report template ............................................................................................................ 8 

4.6. The program options ............................................................................................................................... 8 

4.6.1. Customizing program settings ........................................................................................................... 8 

4.6.2. Selecting the interface language ........................................................................................................ 9 

4.7. Closing the program ............................................................................................................................... 9 

5. The program license ........................................................................................................................................ 9 

5.1. Types of licenses .................................................................................................................................... 9 

5.2. Information about the developer ............................................................................................................. 9 

6. Appendix ....................................................................................................................................................... 10 

6.1. List of files ............................................................................................................................................ 10 

6.2. The attributes of visual objects ............................................................................................................. 10 
 



Report Designer "IsimsoftwareReport" User 

Manual 
3  

1. Introduction 

The program is developed for visual design of forms of reports and documents. 

Features: 

- choice of portrait or landscape orientation of the report form; 

- design of the form using text and graphic elements; 

- configure report filling with dynamic data from the application database; 

- grouping of data in the table section; 

- setting up headers and page numbers; 

- preview with scaling; 

- WYSIWYG visualization technology; 

- localized interface. 

 

 
 

2. Terms & Definitions 

Dynamic data: An information from the database displayed in the report. 

Object attributes: Object properties that determine its appearance and location on the page: size, position on 

the page, font, color, etc. 

Static data: A collection of text and graphic objects forming a report form. 

Report form: A visual representation of the report, containing static data and information on the orientation of 

the report pages. 

Report template: A report form with rules for filling it with dynamic data. 

Visual object: A text or graphic primitive, characterized by a set of its attributes. 

 
 

3. User interface 

The program interface consists of a main window and dialog boxes. 

 
 

3.1. Main windows 

The main window of the program consists of the main menu, the toolbar, the object tree, the properties panel, 

the page layout panel, the preview panel and the status bar. 
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Main menu contains commands grouped by function. 

Toolbar buttons are used for quick access to frequently used commands. 

At the bottom of the main window of the program is a status bar, in which information is displayed about the 

open template file, scale, license, current date and time. 

 
 

3.2. Main menu 

 
3.2.1. File menu items 

New Template - creating a new template. 

Open Template… - loading a template from a file. 

Save - saving an open template. 

Save as… - saving an open template to a new file. 

Print… - preview and printing an open template. 

Exit - closing the program. 

 
3.2.2. Objects menu items 

Add Object… - adding a new object to the page. 

Delete Object - deleting the selected object. 

 
 

3.2.3. View menu items 

Refresh - redrawing the preview pane. 

Zoom In - increasing in scale of the preview pane. 

Zoom Out - reducing in scale of the preview pane. 

Show grid - displaying the grid in the page layout panel. 

Show ruler - displaying of a horizontal ruler in the page layout panel. 

 
 

3.2.4. Options menu items 

Settings - adjusting program settings. 
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3.2.5. Help menu items 

About… - obtaining information about the program version and the contact data of the developer. 

 

 

 
4. Working with the software 

 
4.1. The basic concepts 

The report can have a vertical (portrait) or horizontal (landscape) orientation. To specify the orientation of the 

report pages in the object tree, select Report Template and specify the required value in the properties panel. 

The report is divided into functional areas, called report sections. Depending on the purpose, the sections can 

be presented in the report both once and repeated on each page of the report. 

The number of pages in the report is determined by the volume of the dynamic data and the specified size of 

the report sections. To change the size of a section, select the section in the object tree, and in the properties panel, set 

the required value. 

In each section, visual objects of certain types can be placed. 

All types of visual objects are listed in the table. 

No Object Type Note 

1 Text Text line 

2 Line Horizontal or vertical line 

3 Image Image from file 

4 Data Field Dynamic data from the application database * 

5 Current Date Date of report printing 

6 Current Time Time of report printing 

7 Page Number Page number 

* Note: the names of the data fields available for each type of report are listed in the annex to the main 

program user's manual. 

The selection of the section is carried out in the object tree. The selected section is highlighted with a blue 

border in the page layout panel. 

 

 
4.1.1. Page Margins section 

The section is designed to accommodate information that is repeated on each page of the report: page number, 

report print date, time of printing, logo, etc. 

The section can accommodate objects of any type. 

Section attributes are the sizes of the report page fields. 

 
4.1.2. Report Header section 

The section is intended to place the report headers: the name of the report, the name of the organization, the 

reporting period, requisites, the logo of the organization, etc. 

The section is displayed once, at the top of the first page of the report. 

It is possible to place objects of all types in this section, except for the Page Number. 

The height of the section is specified by the attribute "Height". The width of the section is equal to the width of 

the page, minus the size of the page fields. 
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4.1.3. Table Header section 

The section is intended for placement of the table header elements: the names of the columns of the table, the 

graphic design of the column boundaries. 

The section is displayed on each page of the report containing tabular data. On the first page this section is 

placed directly under the report header. On the following pages this section is placed at the top of the page. 

In the section it is possible to place objects of types: Text, Line. 

The height of the section is specified by the attribute "Height". The width of the section is equal to the width of 

the page, minus the size of the page fields. 

 
 

4.1.4. Group Header section 

The section is intended for displaying the group header if it is necessary to group the rows in the table by a 

matching data field. 

The number of pages will depend on the amount of dynamic data (the number of rows in the table) and the 

height of the table row. 

In the section, it is possible to place type objects: Line, Data Field. 

The height of the table row is specified by the attribute "Height". The width of the section is equal to the width 

of the page, minus the size of the page fields. 

 
 

4.1.5. Data Rows section 

The section is intended for placement of tabular data: dynamic data from the application database and graphic 

design of table cells. 

The number of pages will depend on the amount of dynamic data (the number of rows in the table) and the 

height of the table row. 

In the section, it is possible to place type objects: Line, Data Field. 

The height of the table row is specified by the attribute "Height". The width of the section is equal to the width 

of the page, minus the size of the page fields. 

 
 

4.1.6. Report Footer section 

The section is intended for placement of summary information: summary data, requisites for signing, etc. 

The section is displayed once, on the last page of the report. 

In the section it is possible to place objects of all types. 

The height of the section is specified by the attribute "Height". The width of the section is equal to the width of 
the page, minus the size of the page fields 

 

 
4.2. Edit a report template 

Changing the template of an existing report is done to add new visual objects, delete existing objects from the 

report, or change the attributes of objects. 

To make changes to an existing report template, select the "Open template" option in the "File" menu or click 

the "Open template" button in the toolbar. 

The "Open file" dialog box appears. Select the file that contains the report template. Note: the list of files with 

ready-made report templates is given in the appendix to the user's guide of the main program. The selected template will 
be opened in the designer. The file name will be displayed in the status bar. 

 
 

4.2.1. Select an object 

The choice of object is carried out in the following ways: 

- click on the object in the page layout panel; 
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- selecting a node with the name of the object in the object tree 

The selected object is highlighted with a dotted blue frame. 

 
4.2.2. Change the position of the object 

You can change the position of an object in any of the following ways: 

1) Move the mouse cursor over the object, press the left mouse button, and while holding it, move the object to 

a new location and release the mouse button. 

2) Select the object. In the properties panel, enter the new values for the object's coordinates. The position of 

the object relative to the page will be changed. 

 
 

4.2.3. Resize an object 

You can resize an object in any of the following ways: 

1) Move the mouse pointer over the border of the object, click the left mouse button, and while holding it, 

move the object's border horizontally or vertically and release the mouse button. 

2) Select the object. In the properties pane, enter new values for the width and height of the object. The size of 

the object will be changed. 

 
 

4.2.4. Change object attributes 

To change the attributes of an object, select the object. In the properties panel, enter a new attribute value or 

select it from the list of available options. The list of available attributes depends on the type of object. A complete list 

of possible attributes is given in the appendix. 

 
 

4.2.5. Add an object 

To add a new visual object to the report, specify the current section for placing the object by selecting a section 

by clicking on the section name in the object tree. Select the item "Add object" in the "Objects" menu or click the "Add 

object" button. 

The «Add object» dialog box appears. 

Select the required object and click the "Apply" button. A new visual object of the selected type will appear in 

the page layout panel and the object name will be added to the object tree by default. 

Select the newly added object, specify its location and dimensions. Set the values of required attributes in the 

properties panel. 

 
 

4.2.6. Delete an object 

To delete a visual object from the report, select it in the page layout panel and select "Delete object" in the 

context menu. 



Report Designer "IsimsoftwareReport" User 

Manual 
8  

An alternative way to delete an object is to select an object by clicking in the object tree or in the page layout 

panel. Select "Delete object" in the "Objects" menu or click the "Delete object" button in the toolbar. 

To delete an object, the program will ask for confirmation. 

 
 

4.3. Create a report template 

The easiest way to create a new report template is to select one of the existing reports as a basic one, make 

changes to it and save it to a new file. However, it is possible to create a report template from scratch. 

To create a report, click the "New template" button in the "File" menu or click the "New template" button in 

the toolbar. The next steps are similar editing a report template. 

 
 

4.4. Save a report template 

After you make changes to the report template, you must save it. To save the template in the same file, select 

"Save" in the "File" menu. Or click the "Save" button in the toolbar. 

To save the template in a new file, select "Save As" in the "File" menu. The "Save Report Template" dialog 

box appears. Enter the file name to save the template. The template will be saved in a file. 

 
 

4.5. View and print a report template 

The program allows you to view the template, both in the preview panel and in the "Preview" dialog box. 

To view the template in the preview pane, choose Refresh from the View menu or click the Refresh button on 

the toolbar. A template with all visual objects will be displayed in the preview pane. To change the scale of the 

template, use the "Scale" item in the "View" menu and the "Zoom in" and "Zoom out" buttons on the toolbar. 

To view a report template filled with dynamic data, as well as a multi-page report, select "Print" in the "File" 

menu or click the "Print" button on the toolbar. The report template will be displayed in the preview window. 

To print, click the "Print" button in the "Preview" window. 

 
 

4.6. The program options 

 
4.6.1. Customizing program settings 

To configure program settings, select "Settings" in the "Options" menu. The "Settings" dialog box appears. 

To change the background color of the page layout bar, click the "Background color" panel. The color 

selection screen appears. Select the color and click "OK." 

To change the grid step, select the new value in the "Grid size" field. 

The "Preview" panel allows you to specify the parameters for filling a report template with dynamic data for 

checking a multi-page report. 

To save the changes, click "Save". 
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4.6.2. Selecting the interface language 

The program supports a multilingual interface. By default, the interface language of the program corresponds 

to the operating system language. 

To change the language of the program interface, click on the button  in the toolbar and select the 
desired interface language in the list that appears. A confirmation message will appear on the screen. 

After confirmation, the program will be automatically closed. After restarting the program will get the selected 

interface language. 

 
 

4.7. Closing the program 

Select "Exit" in the "File" menu. The program will ask for confirmation: 

Select the "Yes" button to complete the work or the "No" button to return to the program 

 
 

5. The program license 

 
5.1. Types of licenses 

The functionality of the program depends on the type of license used.  

 

The program comes with a license by default. Information about the available license is displayed in the  status 

bar. 

 
 

5.2. Information about the developer 

For any comments, suggestions and questions about the operation of the program, please contact the developer. 

Isimsoftware. 

info@isimsoftware.com 

http://www.isimsoftware.com 

mailto:info@isimsoftware.com
http://www.isimsoftware.com/
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6. Appendix 

 

6.1. List of files 

The table contains a list of files included in the software package. 

 

No File/Folder Note 

1 IsimsoftwareReport.exe Executable File 

2 IsimsoftwareReportLib.dll Database File 

3 IsimsoftwareReport_Manual.pdf User Manual 

4 Reports Report Templates Folder 

 
 

6.2. The attributes of visual objects 

The table contains a list of all possible attributes of visual objects 

 

No Attribute Note 

1 Type Object type (read-only) 

2 Name The name of the object to identify it in the object tree 

3 Left The X coordinate of the object in mm 

4 Top The Y coordinate of the object in mm 

5 Width Object width in mm 

6 Height Object height in mm 

7 Alignment Align text vertically and horizontally 

8 Font The font style and font size of the object text 

9 Text Text line 

10 Orientation Orientation of the line (vertically or horizontally) 

11 Thickness Line thickness in mm 

12 File name Path to file with image 

13 Field name Name of the data field in the application object model 

14 Value Default field value 

 


